Skip to content
VulniPulse
Highest advisory severityHigh 2 vendors · 2 advisories

CVE-2026-53917: Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client…

Compare the source-linked records below. Ratings and product/version details belong to each advisory; they are not a single CVE-wide score or proof that every listed product is affected. How VulniPulse collects and checks evidence.

CVE-2026-53917 key facts

CISA KEV
Not listed (catalog checked )
Highest advisory severity
High
CVSS base score
7.5 (Apache), 6.5 (Red Hat)
CVSS vector
  • CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H (Red Hat)
Weakness
CWE-770
Fixed releases
  • Apache: 6.2.7, 5.19.8
  • Red Hat: 6.2.7, 5.19.8
Vendor advisories
2 from Apache, Red Hat
VulniPulse record
Published · Updated

Scores, vectors, weaknesses and fixed releases are quoted from vendor advisories that cover only CVE-2026-53917; bulletin-wide values are not repeated here.

Is CVE-2026-53917 exploited?

No exploitation is reported in the sources VulniPulse tracks: CVE-2026-53917 is not in the CISA KEV catalog (checked ) and no tracked advisory for it reports exploitation. That is not proof the vulnerability cannot be exploited.

How do I fix CVE-2026-53917?

Upgrade to a fixed release named by the vendor:

  • Apache: 6.2.7, 5.19.8
  • Red Hat: 6.2.7, 5.19.8
  • Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability. (Red Hat)

Get an email when Apache publishes the next one.

See Apache's last 90 days of advisories first. Then choose one product with live alerts free for life, or a free month of real-time alerts on everything with the severity, the fixed version and the vendor's link (card needed, then US$15/month; we email you before the first charge).

Alert me about Apache

Vendor advisory comparison

Apache

1 advisory
  • Advisory severityHigh7.5

    High [CVE-2026-53917] Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client…

    CVE-2026-53917Source published Source updated

    Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client, Apache ActiveMQ Broker. An authenticated user can cause a broker DoS by sending a crafted OpenWire Message with a large encoded size value for the map. OpenWire message property maps are unmarshaled without size validation which can trigger OOM and crash the broker. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Client: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

    Affected products in this advisory
    • Apache ActiveMQ All
    • Apache ActiveMQ Client
    • Apache ActiveMQ Broker
    Source-reported affected versions
    • 6.0.0 through 6.2.7
    • 6.0.0 through 6.2.7.
    Source-reported fixed versions
    • 6.2.7
    • 5.19.8
    Mitigation guidance
    No mitigation guidance extracted; consult the source.

Red Hat

1 advisory
  • Advisory severityMedium6.5

    Medium [CVE-2026-53917] Denial of Service via crafted OpenWire Message

    CVE-2026-53917Source published Source updated

    Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client, Apache ActiveMQ Broker. An authenticated user can cause a broker DoS by sending a crafted OpenWire Message with a large encoded size value for the map. OpenWire message property maps are unmarshaled without size validation which can trigger OOM and crash the broker. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue. This lack of size validation during unmarshaling can lead to an out-of-memory error, causing the broker to crash and resulting in a Denial of Service (DoS). Red Hat products ship Apache ActiveMQ Classic components as transitive dependencies. The vulnerability is in the OpenWire message property map unmarshalling code in…

    Affected products in this advisory
    • Red Hat AMQ Broker 7
    • Red Hat AMQ Clients
    • Red Hat build of Apache Camel for Spring Boot 4
    • Red Hat Data Grid 8

    6 more entries in the full advisory.

    Source-reported affected versions
    • < 5.19.8
    • < 6.0.0
    • < 6.2.7
    Source-reported fixed versions
    • 6.2.7
    • 5.19.8
    Mitigation guidance
    • Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
All Apache advisories

Follow CVE-2026-53917 in the free weekly digest

Every Monday: whether it was added to CISA KEV, reported exploited, got a fix or changed severity, plus the week's critical and high advisories.

Free, no account. Confirm by email; unsubscribe in one click. Choose vendors and severity

Browse the latest tracked CVEs or the CVEs listed in CISA KEV.

iPhone and Android apps · New on the App Store

Get alerts for new CVEs on your phone.

Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.

Matching phone alertsOptional email delivery