High [CVE-2026-0309] PAN-OS: Authenticated Command Injection in CLI with Luna HSM Configuration
This high-severity Palo Alto Networks advisory covers CVE-2026-0309 affecting PAN-OS.
Aggregated and source-linked by VulniPulse. Data sources, validation and limitations.
VulniPulse record published Record updated
Get an email when Palo Alto Networks publishes the next one.
VulniPulse checks Palo Alto Networks's security advisories around the clock and emails you new ones with the severity, the fixed version and the vendor's link. First month free, then US$15/month; we email you before the first charge.
Summary
CVE-2026-0309 PAN-OS: Authenticated Command Injection in CLI with Luna HSM Configuration
- PAN-OS < 12.2.3
- PAN-OS < 12.1.4-h10
- PAN-OS < 11.2.4-h21
- PAN-OS < 11.1.4-h36
- PAN-OS < 10.2.7-h37
Official advisory · high-confidence parse· fetched 13 days ago·verify at source
- PAN-OS >= 12.2.3
- PAN-OS >= 12.1.10
- PAN-OS >= 12.1.7-h5
- PAN-OS >= 12.1.4-h10
- PAN-OS >= 11.2.13-h2
- PAN-OS >= 11.2.10-h14
- PAN-OS >= 11.2.7-h20
- PAN-OS >= 11.2.4-h21
- PAN-OS >= 11.1.16-h2
- PAN-OS >= 11.1.13-h12
- PAN-OS >= 11.1.10-h33
- PAN-OS >= 11.1.7-h10
- PAN-OS >= 11.1.6-h38
- PAN-OS >= 11.1.4-h36
- PAN-OS >= 10.2.18-h10
- PAN-OS >= 10.2.16-h10
- PAN-OS >= 10.2.13-h24
- PAN-OS >= 10.2.10-h40
- PAN-OS >= 10.2.7-h37
Official advisory · high-confidence parse· fetched 13 days ago·verify at source
Mitigation checklist
- VersionMinor VersionSuggested SolutionCloud NGFW No action needed.
- PAN-OS 12.2 12.2.0 through 12.2.2 Upgrade to 12.2.3 or later.
- PAN-OS 12.1 12.1.8 through 12.1.9 Upgrade to 12.1.10 or later. 12.1.5 through 12.1.7-h* Upgrade to 12.1.7-h5 or 12.1.10 or later. 12.1.2 through 12.1.4-h* Upgrade to 12.1.4-h10 or 12.1.10 or later.
- No known workarounds exist for this issue.
Official advisory · high-confidence parse· fetched 13 days ago·verify at source
More Palo Alto Networks advisories
- CVE-2026-111497Oct 26, 2026Portfolio Status: Impact of Brotli Vulnerability on Palo Alto Networks Products
- CVE-2026-109618Oct 21, 2026Impact of Critical Vulnerabilities in PHP (, CVE-2026-109619) on Palo Alto Networks
- CVE-2026-0317Oct 14, 2026PAN-OS: Denial of Service Vulnerability
- CVE-2026-0322Oct 14, 2026PAN-OS: Authenticated Remote Code Execution (RCE) in the Management Interface
- CVE-2026-0319Oct 14, 2026PAN-OS: Improper Input Handling Vulnerability
- CVE-2026-0316Oct 14, 2026PAN-OS: Stored Cross-Site Scripting (XSS) Vulnerability
Android app · Google Play
Monitor future Palo Alto Networks CVEs from your phone.
Choose a whole vendor or a precise platform, then receive matching security advisories by phone notification, email, or both. Coverage follows 34 official vendor sources and 160+ reviewed platform categories.
Discussion(0)
No comments yet. Share field notes, upgrade gotchas, or questions — verify against the vendor advisory before acting on community advice.
Sign in to join the discussion.